PDA

View Full Version : Engine oil light


straight6
07-29-2004, 02:05 AM
I was cruising down the highway at about 80-85mph in my car turning about 2250-2500RPM and after about 5-10min the check light came on and I look up and the light for engine oil is iluminated. I pull over to the emergency lane and turn off the engine. I sat for a few seconds and restarted the engine. When the engine was restarted the light was off. This has hapened a few times now all under similar circumstances. The oil level is fine.

Is this light for oil pressure, oil temperature, or oil level and what made it come on?

If it's for oil temperature should I install the 325i oil-cooler to remedy the problem?

Please help I don't want to hurt my engine.

x628x
07-29-2004, 02:25 AM
the one in the top right of the check panel? thats the oil level i believe. it comes on for me about every 2k miles (or it did before my odometer broke)

Giga Shadow
07-29-2004, 03:01 AM
^I second that.

Oil levels.

Riverwino
07-29-2004, 11:27 AM
i think the check oil light up by the mirror is for oil pressure. I assume this since my car currently leaks oil of the rear main seal and after the light comes on i will add oil back up to the top fill mark on the stick and the light will still be on for a bit, but it will go off righta way if i drain off the air from the filter.


i may be wrong, maybe the sender needs to resaturate or something

x628x
07-29-2004, 03:31 PM
im pretty sure its the oil level light, because it comes on when the oil is low.

AdamF
07-29-2004, 04:42 PM
It's oil level. The oil pressure light is the one all the way to the right next to the battery on the insturment cluster.

straight6
07-30-2004, 01:34 AM
Then why does it come on because the oil level is always fine?

And it only happens when under those circumstances.

AdamF
07-30-2004, 11:27 PM
Then why does it come on because the oil level is always fine?

And it only happens when under those circumstances.

Because the plug is probably loose, or the sensor is going out or clogged up or something.

bmwsmurf
08-24-2004, 01:46 AM
Very likely bad sensor if your oil level is ok.

straight6
08-24-2004, 09:30 PM
I figured it out. I added a 1/2quart and that brought the oil level up to the 5/8 level in the safety zone approximately. The light hasn't come on since then. I think that the prolonged cruising at 2000-3000rpm pumped enough oil to the head and it didn't flow back down to the sump so the level light came on.

But the problem is solved.