PDA

View Full Version : cutting out....


85BMW318i
03-10-2007, 06:30 PM
last night was a hell of a night for the super eta. I got half my tire's n mud cuz my sister got her neon stuck. I tore my exaust in the back up a little. After i got out of all the mud i was running and when the rpms get high it will cut out and check engine light come's on. it's will continue to run just cut's out really bad. like in 2nd at about 35-40 it will cut out and check engine light come's on and goe's back off. so what could it be? fuel pump? spark??? what???? i got a video phone anyone who want's me to record a video of what happen's send me a e-mail address to send it to...thanks..

bmwdude
03-10-2007, 09:12 PM
If you're getting a check engine light, then something is at least getting stored on the On-Board Diagnostics Fault Codes. Many never bother with this method of troubleshooting, but I like to start off what my car tells me instead of blindly wandering away. Do you know how to read them?

My experiences with immediate high rpm cut outs(like hitting a cbrick wall) were always "excessively rich" fuel mixtures.

twoJ's
03-10-2007, 10:49 PM
AFM? Grab your bentley and test it out.

85BMW318i
03-12-2007, 04:39 PM
i had it put on a computer faulty indicator light faulty fuel pump relay in tank fuel ventilation all 6 injectors so what u all think 3k above i cant mash it or it cut out n stuff check engine light blinks and it goe's to 2500rpms

twoJ's
03-12-2007, 08:33 PM
I suggest that you learn how to make complete sentences. Then we could understand what you just wrote.

bmwdude
03-13-2007, 01:36 AM
^^^+1! :D

85BMW318i
03-13-2007, 02:52 AM
i'm sorry just not alot of time. I dunno what it is. not cap or rotar just lie when i hit 3 k the check engine light come's on and it drop's to about 2500. When i don't run it hard it won't do it. I have no clue it's gotta be a sensor. i showed what the computer said

fault indicator light
faulty in take ventilation
faulty fuel pump relay
injector cly 246 and 135

I'v completed them as good as i can

nomade30
03-13-2007, 05:49 AM
AFM then i would clean off your tranny sensors that might be it

85BMW318i
03-13-2007, 09:47 PM
t's a 5 speed. how would i know what afm would work i know the one from the 325es wouldn't work. their's a 89 325i in the junk yard i guess i'll see if it work's.

I really question if it's the fuel pump losing power. i got a voltmeter and i'm gonna run down every wire running power to it. I need a list of the fuse box all of em. i got some of them wrong.

It also look's like i got a leaking injector and a small leak coming from behind the afm. I'm gonna seal it tommrow. I need help with this car, I cannot understand why it doe's this. I don't wanna throw it in a shop. I wanna fix this...

I said the computer read faulty indicator light. I think that has to do with the S.I board cuz i replaced it with another 1 and it was off from the one i took out. Whenever he was done with the computer, the lights was green but when i started the whole thing shut's off so that's why i think it read faulty indicator light.


help me guy's!!!!!!